configure.ac: Bump libtool/library version from 1:0:0 to 2:0:0.