onewire_link: Convert to PD API version 3.