Implement LogicSegment::get_surrounding_edges() and use it
[pulseview.git] / pv / data / logicsegment.cpp
2018-09-26 Soeren ApelImplement LogicSegment::get_surrounding_edges() and...
2018-05-21 Uwe Hermannlogicsegment.cpp: Constify a few variables.
2018-05-21 Uwe HermannLogicSegment::pow2_ceil(): Fix potentĐľal integer overflow.
2018-05-19 Uwe Hermannlogicsegment.cpp: Suggest inlining of pack_sample(...
2018-05-19 Uwe Hermannlogicsegment.cpp: Add missing config.h #include.
2018-05-02 Soeren ApelLogicSegment: Readability changes
2018-01-09 Soeren ApelAdd segment_id to all segment classes
2018-01-09 Soeren ApelLogicSegment: Don't use new/delete in get_unpacked_sample()
2018-01-09 Soeren ApelLogicSegment: Limit end in get_subsampled_edges() if...
2017-07-05 Soeren ApelMake get_raw_samples() use provided mem instead of...
2017-03-28 Uwe HermannUse alphabetical order for #includes.
2017-03-23 Uwe HermannRandom simplifications, cosmetics/whitespace/consistenc...
2017-03-23 Uwe HermannRemove unused "using" declarations.
2017-03-22 Soeren ApelLogicSegment: Remove constructor requiring sigrok:...
2017-03-22 Soeren ApelLogicSegment: Make constructor and append_payload(...
2017-03-18 Uwe HermannDon't use std:: in the code directly (where possible).
2017-03-11 Uwe HermannUse emplace_back() where possible.
2017-03-11 Uwe HermannUse bool literals for boolean values.
2017-03-11 Uwe HermannDon't use deprecated headers.
2017-02-19 Soeren ApelSegment: Do not alter chunks when there are active...
2017-02-15 Soeren ApelProvide notifiers for when signal data changes
2017-02-08 Soeren ApelSwitch segment storage from single vector to vector...
2017-02-02 Soeren ApelUnify get_samples() semantics for AnalogSegment and...
2017-01-07 Gerhard Sittiglicense: remove FSF postal address from boiler plate...
2016-01-31 Soeren ApelFix clang warning: shifting a negative signed value...
2015-12-26 Uwe HermannVarious minor whitespace and consistency fixes.
2015-11-04 Uwe HermannMinor whitespace cosmetics.
2015-06-11 Joel HoldsworthReplaced NULL with nullptr
2015-01-17 Uwe HermannUpdate for libsigrokcxx rename.
2015-01-01 Uwe HermannUse <cmath> in favor of <math.h> everywhere.
2014-12-10 Joel HoldsworthSnapshot: Renamed to Segment