libsigrokdecode.git
7 days ago Gerhard Sittigpjon: introduce decoder for PJON frame inspection master
7 days ago Gerhard Sittigpjdl: introduce decoder for PJON single wire serial...
8 days ago Konrad Beckmannjtag: Use list.append instead of insert
2020-05-26 Uwe Hermannnrf905: Drop non-existent OUTPUT_PYTHON output.
2020-05-26 Uwe Hermannnrf905: More readable annotation byte values.
2020-05-26 Uwe Hermannnrf905: Drop all print() calls.
2020-05-26 Uwe Hermannnrf905: Simplify a few code snippets.
2020-05-26 Uwe Hermannnrf905: Use SrdIntEnum for annotation classes.
2020-05-26 Uwe Hermannnrf905: Add missing 'tags' item.
2020-05-26 Uwe Hermannntf905: Add/rename required self.reset() method.
2020-05-26 Jorge SollaAdd decoder for Nordic Semiconductor nRF905 chip
2020-05-22 Uwe HermannUse PyLong_FromUnsignedLongLong() where needed.
2020-05-21 Uwe Hermanntype_decoder.c: Workaround for a compiler warning.
2020-05-21 Teo Perisanuadxl345: Update register meaning for 0x21, 0x22, 0x23...
2020-04-11 Uwe Hermannad79x0: Rename the 'ref' option to 'vref'.
2020-04-11 Uwe Hermannad79x0: Reduce unnecessarily many voltage formats.
2020-04-11 Uwe Hermannad79x0: Fix the tags metadata item.
2020-04-11 Uwe Hermannad79x0: Avoid duplicated annotation class/row IDs.
2020-04-11 Teo PerisanuAdd AD79x0 decoder.
2020-04-11 Uwe Hermannad5626: Always use the same number of decimal places.
2020-04-11 Uwe Hermannad5626: Rename an annotation class.
2020-04-11 Uwe Hermannad5626: Drop unnecessary annotation_rows item.
2020-04-11 Uwe Hermannad5626: Fix the tags metadata item.
2020-04-11 Teo PerisanuAdd AD5626 decoder.
2020-04-11 Uwe Hermannltc242x: Reduce unnecessarily many voltage formats.
2020-04-11 Uwe Hermannltc242x: Put channel voltages on different annotation...
2020-04-11 Uwe Hermannltc242x: Use plural for annotation rows, avoid duplicates.
2020-04-11 Uwe Hermannltc242x: Rename the 'ref' option to 'vref'.
2020-04-11 Uwe Hermannltc242x: Fix the tags metadata item.
2020-04-11 Teo PerisanuAdd LTC242x decoder.
2020-04-11 Uwe Hermannltc26x7: Put channel voltages on different annotation...
2020-04-11 Uwe Hermannltc26x7: Reduce unnecessarily many voltage formats.
2020-04-11 Uwe Hermannltc26x7: Fix the default for the 'chip' option.
2020-04-11 Uwe Hermannltc26x7: Option renames for consistency.
2020-04-11 Uwe Hermannltc26x7: Fix the tags metadata item.
2020-04-11 Uwe Hermannltc26x7: Drop unnecessary annotation_rows item.
2020-04-11 Teo PerisanuAdd LTC26x7 decoder.
2020-04-11 Uwe Hermannadxl345: Fix incorrect rate value in handle_reg_0x2c().
2020-04-10 Uwe Hermannadxl345: Use all-lowercase method named for handle_reg_*.
2020-04-10 Uwe Hermannadxl345: Use SrdIntEnum for the state machine.
2020-04-10 Uwe Hermannadxl345: Use SrdIntEnum for annotation classes.
2020-04-10 Uwe Hermannadxl345: Fix scale factor in handle_reg_0x22().
2020-04-10 Uwe Hermannadxl345: Shorten/simplify self.putbs() invocations.
2020-04-10 Uwe Hermannadxl345: Shorten/simplify a few code snippets.
2020-04-10 Teo PerisanuAdd ADXL345 decoder.
2020-01-13 Uwe Hermannsdcard_sd: Automatically generate token field annotatio...
2020-01-12 Uwe Hermannsdcard_sd: Put 0/1 bits in different annotation classes.
2020-01-12 Uwe Hermannsdcard_sd: Put card status fields in their own annotati...
2020-01-12 Uwe Hermannsdcard_sd: Add basic support for CSD register fields.
2020-01-12 Uwe Hermannsdcard_sd: Add basic support for CID register fields.
2020-01-12 Uwe Hermannsdcard_sd: Rename some annotation classes.
2020-01-11 Uwe Hermannsdcard_sd: Use a Bit class to improve readability.
2020-01-11 Uwe Hermannsdcard_sd: Replace a hardcoded number for better readab...
2020-01-10 Uwe Hermannsdcard_sd: Clarify some variable/argument names.
2020-01-10 Uwe Hermannsdcard_sd: Remove a list that needs manual maintenance.
2020-01-10 Uwe Hermannsdcard_sd: Use correct annotation class for R2.
2020-01-10 Uwe Hermanncjtag: Use SrdIntEnum for cJTAG states.
2020-01-10 Uwe Hermannsda2506: Use SrdIntEnum for pins.
2020-01-10 Uwe Hermanntlc5620: Use SrdIntEnum for pins.
2020-01-10 Uwe Hermannmaple_bus: Use SrdIntEnum for pins.
2020-01-10 Uwe Hermannsdcard_sd: Use SrdIntEnum for pins.
2020-01-10 Uwe Hermannsdcard_sd: Simplify self.putr() invocations.
2020-01-10 Uwe Hermannsdcard_sd: Put responses in their own annotation classes.
2020-01-10 Uwe Hermannsdcard_sd: Use SrdIntEnum for annotation classes.
2020-01-10 Uwe Hermanncjtag: Use SrdStrEnum for the state machine.
2020-01-10 Uwe Hermannjtag: Use SrdStrEnum for the state machine.
2020-01-10 Uwe Hermannedid: Use SrdIntEnum for the state machine.
2020-01-10 Uwe Hermannsdcard_sd: Use SrdStrEnum for the state machine.
2020-01-10 Uwe Hermannsrdhelper: Add SrdStrEnum with various helper methods.
2020-01-10 Uwe Hermannusb_signalling: Use SrdIntEnum for the state machine.
2020-01-10 Uwe Hermannjtag_ejtag: Use SrdIntEnum for annotation classes.
2020-01-10 Uwe Hermannmcs48: Use SrdIntEnum for annotation classes.
2020-01-10 Uwe Hermannac97: Rename Pins class to Pin.
2020-01-10 Uwe Hermannac97: Use SrdIntEnum for annotation/binary/pin classes.
2020-01-10 Uwe Hermannspiflash: Use SrdIntEnum for annotation classes.
2020-01-10 Uwe Hermannsdcard_spi: Use ternary operator where possible.
2020-01-10 Uwe Hermannsdcard_spi: Use SrdIntEnum for annotation classes.
2020-01-10 Uwe Hermannds1307: Use SrdIntEnum for annotation classes.
2020-01-10 Uwe Hermannds1307: Consistently use _ instead of - for various...
2020-01-10 Uwe Hermanncc1101: Use SrdIntEnum for annotation classes.
2020-01-10 Uwe Hermannamulet_ascii: Use SrdIntEnum for annotation classes.
2020-01-10 Uwe Hermannsrdhelper: Add SrdIntEnum with various helper methods.
2020-01-08 Uwe Hermanncjtag: Drop no longer needed _real variable name suffix.
2020-01-08 Uwe Hermanncjtag: Give each cJTAG state its own annotation class.
2020-01-08 Uwe Hermanncjtag: Use correct TCKC/TMSC channel names.
2020-01-08 Uwe Hermanncjtag: Drop some unused method arguments.
2020-01-08 Uwe Hermanncjtag: Drop non-existing channels from the decoder.
2020-01-08 Uwe Hermanncjtag: Use ternary operator where possible.
2020-01-08 Uwe Hermanncjtag: Use += operator where possible.
2020-01-08 Uwe Hermanncjtag: Drop various unneeded parenthesis.
2020-01-08 Uwe Hermanncjtag: Use plural for annotation row IDs/names.
2020-01-08 Kongou Hikaricjtag: Add cJTAG OSCAN1 decoder.
2020-01-08 Uwe Hermanncjtag: Use an exact copy of the jtag PD as basis for...
2020-01-05 Uwe Hermannspiflash: Don't use ambiguous annotation class names.
2020-01-04 Gerhard Sittigdmx512: stack DMX512 on top of UART and improve usability
2020-01-04 Gerhard Sittigdmx512: remove previous implementation before replacing it
2020-01-04 Gerhard Sittigps2: end data byte at rising clock edge of the stop bit
2020-01-02 Stephan Thieleflexray: fix annotation for 'frame end sequence'
2020-01-01 Uwe Hermannamulet_ascii: Minor consistency fix.
2020-01-01 Uwe Hermannxfp: Add annotation rows.
next