Bump libsigrokdecode requirement to >= 0.4.0 (API change).
authorUwe Hermann <uwe@hermann-uwe.de>
Thu, 20 Aug 2015 18:26:50 +0000 (20:26 +0200)
committerUwe Hermann <uwe@hermann-uwe.de>
Thu, 20 Aug 2015 18:26:50 +0000 (20:26 +0200)
README
configure.ac

diff --git a/README b/README
index ebfdcfacd1166028365971b31d1a430264f8cbd4..366642c212eade12fc388b45b5d9dfd47a78357d 100644 (file)
--- a/README
+++ b/README
@@ -29,7 +29,7 @@ Requirements
  - libglib >= 2.24.0
  - Python >= 3.2
  - libsigrok >= 0.3.0
- - libsigrokdecode >= 0.3.0
+ - libsigrokdecode >= 0.4.0
  - python3-coverage
 
 
index 187755930c356d4a00ccc4fbede7b1b373e61403..c8be068e4de76e4b7cd17ccb871f494e505c334e 100644 (file)
@@ -85,7 +85,7 @@ PKG_CHECK_MODULES([libsigrok], [libsigrok >= 0.3.0],
        LIBS="$LIBS $libsigrok_LIBS"])
 
 # libsigrokdecode is always needed.
-PKG_CHECK_MODULES([libsigrokdecode], [libsigrokdecode >= 0.3.0],
+PKG_CHECK_MODULES([libsigrokdecode], [libsigrokdecode >= 0.4.0],
        [AM_CFLAGS="$AM_CFLAGS $libsigrokdecode_CFLAGS";
        LIBS="$LIBS $libsigrokdecode_LIBS"])
 
@@ -119,7 +119,7 @@ else
 fi
 
 # Note: This only works for libs with pkg-config integration.
-for lib in "glib-2.0 >= 2.24.0" "libsigrok >= 0.3.0" "libsigrokdecode >= 0.3.0"; do
+for lib in "glib-2.0 >= 2.24.0" "libsigrok >= 0.3.0" "libsigrokdecode >= 0.4.0"; do
        optional="REQUIRED"
        if `$PKG_CONFIG --exists $lib`; then
                ver=`$PKG_CONFIG --modversion $lib`