Build-depend on the upcoming libsigrok + libsigrokdecode 0.4.0.
authorUwe Hermann <uwe@hermann-uwe.de>
Sat, 18 Jul 2015 16:07:12 +0000 (18:07 +0200)
committerUwe Hermann <uwe@hermann-uwe.de>
Sat, 18 Jul 2015 16:07:12 +0000 (18:07 +0200)
README
configure.ac

diff --git a/README b/README
index 9a3fe1f..0a05ecd 100644 (file)
--- a/README
+++ b/README
@@ -28,8 +28,8 @@ Requirements
  - libtool (only needed when building from git) 
  - pkg-config >= 0.22
  - libglib >= 2.28.0
- - libsigrok >= 0.3.0
- - libsigrokdecode >= 0.3.0
+ - libsigrok >= 0.4.0
+ - libsigrokdecode >= 0.4.0
 
 
 Building and installing
index a4c2a16..64f2aa7 100644 (file)
@@ -64,12 +64,12 @@ AM_CONDITIONAL(WITH_SRD, test x$WITH_SRD = xyes)
 AM_PATH_GLIB_2_0([2.28.0],
        [CFLAGS="$CFLAGS $GLIB_CFLAGS"; LIBS="$LIBS $GLIB_LIBS"])
 
-PKG_CHECK_MODULES([libsigrok], [libsigrok >= 0.3.0],
+PKG_CHECK_MODULES([libsigrok], [libsigrok >= 0.4.0],
        [CFLAGS="$CFLAGS $libsigrok_CFLAGS";
        LIBS="$LIBS $libsigrok_LIBS"])
 
 if test "x$WITH_SRD" = "xyes"; then
-       PKG_CHECK_MODULES([libsigrokdecode], [libsigrokdecode >= 0.3.0],
+       PKG_CHECK_MODULES([libsigrokdecode], [libsigrokdecode >= 0.4.0],
                [CFLAGS="$CFLAGS $libsigrokdecode_CFLAGS";
                        LIBS="$LIBS $libsigrokdecode_LIBS";
                        AC_DEFINE(HAVE_SRD, [1], [libsigrokdecode is available.])]
@@ -98,7 +98,7 @@ echo "Detected libraries:"
 echo
 
 # Note: This only works for libs with pkg-config integration.
-for lib in "glib-2.0 >= 2.28.0" "libsigrok >= 0.3.0" "libsigrokdecode >= 0.3.0"; do
+for lib in "glib-2.0 >= 2.28.0" "libsigrok >= 0.4.0" "libsigrokdecode >= 0.4.0"; do
        if test "$lib" = "libsigrokdecode" -a "$WITH_SRD" != "yes" ; then
                answer="no"
        else