build: Require GLib 2.32.0
authorDaniel Elstner <daniel.kitta@gmail.com>
Fri, 9 Oct 2015 16:33:14 +0000 (18:33 +0200)
committerDaniel Elstner <daniel.kitta@gmail.com>
Fri, 9 Oct 2015 18:33:06 +0000 (20:33 +0200)
This is needed for the G_SOURCE_REMOVE symbolic constant. Although
it would be trivial to make do without it, there is no reason not to
bump the requirement since libsigrok depends on GLib 2.32.0 anyway.

README
configure.ac

diff --git a/README b/README
index 0a05ecdfc247f9a37752cd6c3e542b398699e80d..0f08261eabb8a7c9a28767016214f858da95a5b2 100644 (file)
--- a/README
+++ b/README
@@ -27,7 +27,7 @@ Requirements
  - automake >= 1.11 (only needed when building from git) 
  - libtool (only needed when building from git) 
  - pkg-config >= 0.22
- - libglib >= 2.28.0
+ - libglib >= 2.32.0
  - libsigrok >= 0.4.0
  - libsigrokdecode >= 0.4.0
 
index 7e13190560324b12123f18926051ff83d7870bb0..648f57fed1ea23838d0449aa4aec5a1116fb849f 100644 (file)
@@ -89,7 +89,7 @@ AC_SYS_LARGEFILE
 # Retrieve the compile and link flags for all modules combined.
 # Also, bail out at this point if any module dependency is not met.
 PKG_CHECK_MODULES([SIGROK_CLI],
-       [glib-2.0 >= 2.28.0 libsigrok >= 0.4.0 $SC_PKGLIBS])
+       [glib-2.0 >= 2.32.0 libsigrok >= 0.4.0 $SC_PKGLIBS])
 
 sc_glib_version=`$PKG_CONFIG --modversion glib-2.0 2>&AS_MESSAGE_LOG_FD`
 sc_libsigrok_version=`$PKG_CONFIG --modversion libsigrok 2>&AS_MESSAGE_LOG_FD`
@@ -114,7 +114,7 @@ Compile configuration:
  - C compiler warnings............. $SC_WFLAGS
 
 Detected libraries (required):
- - glib-2.0 >= 2.28.0.............. $sc_glib_version
+ - glib-2.0 >= 2.32.0.............. $sc_glib_version
  - libsigrok >= 0.4.0.............. $sc_libsigrok_version
 
 Detected libraries (optional):