Don't install libs and headers in the 0.1 release.
authorUwe Hermann <uwe@hermann-uwe.de>
Wed, 19 Jan 2011 18:20:44 +0000 (19:20 +0100)
committerUwe Hermann <uwe@hermann-uwe.de>
Wed, 19 Jan 2011 18:20:44 +0000 (19:20 +0100)
The library APIs are not yet usable or finalized, so don't expose the
libs for now. Instead, only install sigrok-cli, the manpages, and
the decoders.

Makefile.am

index 6ae808f68e099c45cd02afdb56d98e92f75df161..f2e4eaed9c8b65f8192b6321cb81470be832db22 100644 (file)
@@ -20,7 +20,8 @@
 
 SUBDIRS = decoders
 
-lib_LTLIBRARIES = libsigrokdecode.la
+# lib_LTLIBRARIES = libsigrokdecode.la
+noinst_LTLIBRARIES = libsigrokdecode.la
 
 libsigrokdecode_la_SOURCES = decode.c
 
@@ -28,8 +29,9 @@ libsigrokdecode_la_CPPFLAGS = $(CPPFLAGS_PYTHON) \
                              -DDECODERS_DIR='"$(DECODERS_DIR)"'
 libsigrokdecode_la_LDFLAGS = $(LDFLAGS_PYTHON)
 
-include_HEADERS = sigrokdecode.h
+# include_HEADERS = sigrokdecode.h
+noinst_HEADERS = sigrokdecode.h
 
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libsigrokdecode.pc
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libsigrokdecode.pc