Drop support for PD API version 2.
[libsigrokdecode.git] / decoder.c
index 64292bc7077452abb45caba3de6b728546824f44..d7395a679eb3d0bac8d9d91a2073cadd4490a1f9 100644 (file)
--- a/decoder.c
+++ b/decoder.c
@@ -686,8 +686,8 @@ SRD_API int srd_decoder_load(const char *module_name)
         * PDs of different API versions are incompatible and cannot work.
         */
        apiver = srd_decoder_apiver(d);
-       if (apiver != 2 && apiver != 3) {
-               srd_exception_catch("Only PD API version 2/3 is supported, "
+       if (apiver != 3) {
+               srd_exception_catch("Only PD API version 3 is supported, "
                        "decoder %s has version %ld", module_name, apiver);
                fail_txt = "API version mismatch";
                goto err_out;