]> sigrok.org Git - libsigrok.git/blobdiff - output/Makefile.am
Hook up output/text directory with autotools.
[libsigrok.git] / output / Makefile.am
index 112ebe724e0aa97a61c27d11c7f8296a784acf6e..b4b4e2c6d51b5a4e9fb326a7fa5fb73f32c433a1 100644 (file)
@@ -17,6 +17,8 @@
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 ##
 
+SUBDIRS = text
+
 # Local lib, this is NOT meant to be installed!
 noinst_LTLIBRARIES = libsigrokoutput.la
 
@@ -25,10 +27,6 @@ libsigrokoutput_la_SOURCES = \
        output_vcd.c \
        output_ols.c \
        output_gnuplot.c \
-       text/text.c \
-       text/bits.c \
-       text/hex.c \
-       text/ascii.c \
        output.c
 
 # Temporarily disabled: output_analog.c
@@ -36,3 +34,6 @@ libsigrokoutput_la_SOURCES = \
 libsigrokoutput_la_CFLAGS = \
        -I$(top_srcdir)/libsigrok
 
+libsigrokoutput_la_LIBADD = \
+       text/libsigrokoutputtext.la
+