]> sigrok.org Git - libsigrok.git/blobdiff - output/Makefile.am
scpi_usbtmc_libusb.c: Fix two error checks.
[libsigrok.git] / output / Makefile.am
index 7e18acfe1bc75eb71676273cc914fcc476f668b5..62f9842c2987034e22a90cb90b6062c23a09c78f 100644 (file)
@@ -1,5 +1,5 @@
 ##
-## This file is part of the sigrok project.
+## This file is part of the libsigrok project.
 ##
 ## Copyright (C) 2011 Uwe Hermann <uwe@hermann-uwe.de>
 ##
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 ##
 
-AM_CPPFLAGS = -DFIRMWARE_DIR='"$(FIRMWARE_DIR)"'
+SUBDIRS = text
 
 # Local lib, this is NOT meant to be installed!
 noinst_LTLIBRARIES = libsigrokoutput.la
 
 libsigrokoutput_la_SOURCES = \
-       output_binary.c \
-       output_text.c \
-       output_vcd.c \
-       output_gnuplot.c \
-       common.c \
+       binary.c \
+       vcd.c \
+       ols.c \
+       gnuplot.c \
+       chronovu_la8.c \
+       csv.c \
+       analog.c \
        output.c
 
 libsigrokoutput_la_CFLAGS = \
-       -I$(top_srcdir)/libsigrok
+       -I$(top_srcdir)
+
+libsigrokoutput_la_LIBADD = \
+       text/libsigrokoutputtext.la