]> sigrok.org Git - libsigrok.git/blobdiff - hardware/common/Makefile.am
configure.ac: libserialport is optional.
[libsigrok.git] / hardware / common / Makefile.am
index ca717510d5fb0796f95b5cd5c561cd9ba0549e44..de8f06c168baeaea23168a7287ed8ff4f18d3a3f 100644 (file)
@@ -22,7 +22,11 @@ SUBDIRS = dmm
 # Local lib, this is NOT meant to be installed!
 noinst_LTLIBRARIES = libsigrok_hw_common.la
 
-libsigrok_hw_common_la_SOURCES = serial.c
+libsigrok_hw_common_la_SOURCES =
+
+if NEED_SERIAL
+libsigrok_hw_common_la_SOURCES += serial.c
+endif
 
 if NEED_USB
 libsigrok_hw_common_la_SOURCES += ezusb.c usb.c