]> sigrok.org Git - libsigrok.git/blobdiff - hardware/common/Makefile.am
scpi_usbtmc_libusb.c: Fix two error checks.
[libsigrok.git] / hardware / common / Makefile.am
index e8a708f31e899b3acb3f7864e8e25eb26e6faad7..7e32ded659677cbfe88a18848718699a87cb6b37 100644 (file)
@@ -1,5 +1,5 @@
 ##
-## This file is part of the sigrok project.
+## This file is part of the libsigrok project.
 ##
 ## Copyright (C) 2011 Uwe Hermann <uwe@hermann-uwe.de>
 ##
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 ##
 
+SUBDIRS = dmm
+
 # Local lib, this is NOT meant to be installed!
-noinst_LTLIBRARIES = libsigrokhwcommon.la
+noinst_LTLIBRARIES = libsigrok_hw_common.la
+
+libsigrok_hw_common_la_SOURCES = scpi.c scpi_tcp.c scpi_usbtmc.c
+
+if NEED_RPC
+libsigrok_hw_common_la_SOURCES += scpi_vxi.c vxi_clnt.c vxi_xdr.c
+endif
+
+if NEED_SERIAL
+libsigrok_hw_common_la_SOURCES += serial.c scpi_serial.c
+endif
+
+if NEED_USB
+libsigrok_hw_common_la_SOURCES += ezusb.c usb.c scpi_usbtmc_libusb.c
+endif
+
+if NEED_VISA
+libsigrok_hw_common_la_SOURCES += scpi_visa.c
+endif
 
-libsigrokhwcommon_la_SOURCES = \
-       ezusb.c \
-       misc.c \
-       serial.c
+libsigrok_hw_common_la_LIBADD = dmm/libsigrok_hw_common_dmm.la
 
-libsigrokhwcommon_la_CFLAGS = \
-       -I$(top_srcdir)/libsigrok
+libsigrok_hw_common_la_CFLAGS = \
+       -I$(top_srcdir)