OpenBSD

From sigrok
Jump to: navigation, search

This page describes how to build/install the sigrok subprojects on OpenBSD.

The instructions were tested on OpenBSD 5.2, older versions may or may not have the required libs/versions to build sigrok.

Distribution packages

There are no official OpenBSD packages/ports yet.

Work-in-progress port can be found here until it enters the official ports distribution: http://people.su.se/~jj/obsd/sigrok.tgz

Tested on i386 and amd64. I could put up precompiled packages for those two platforms if requested.

Building

libsigrok

Installing the requirements:

$ pkg_add -i git autoconf automake libtool glib2 libzip libftdi check
Select autoconf and automake versions with the major versions as listed below (2.69 and 1.12) when asked.

Building:

$ git clone git://sigrok.org/libsigrok
$ cd libsigrok
$ export AUTOCONF_VERSION=2.69 AUTOMAKE_VERSION=1.12
$ ./autogen.sh
$ ./configure
$ make
$ make install

libsigrokdecode

Installing the requirements:

$ pkg_add -i git autoconf automake libtool glib2 python
Select Python version 3.x when asked.

Building:

$ git clone git://sigrok.org/libsigrokdecode
$ cd libsigrokdecode
$ export AUTOCONF_VERSION=2.69 AUTOMAKE_VERSION=1.12 (if you haven't exported those vars already)
$ ./autogen.sh
$ ./configure
$ make
$ make install

sigrok-cli

Installing the requirements:

$ pkg_add -r git autoconf automake libtool glib2

Building:

$ git clone git://sigrok.org/sigrok-cli
$ cd sigrok-cli
$ export AUTOCONF_VERSION=2.69 AUTOMAKE_VERSION=1.12 (if you haven't exported them already)
$ ./autogen.sh
$ ./configure
$ make
$ make install

PulseView

Note: PulseView does not build on OpenBSD at the moment, this is being investigated.

Installing the requirements:

$ pkg_add -i git libtool cmake glib2 qt4 boost-1.42.0p14

Building:

$ git clone git://sigrok.org/pulseview
$ cd pulseview
$ cmake .
$ make
$ sudo make install