FreeBSD

From sigrok
Jump to: navigation, search

This page describes how to build/install the sigrok subprojects on FreeBSD.

The instructions were tested on FreeBSD 10.3, older versions may or may not have the required libs/versions to build sigrok.

Distribution packages

FreeBSD packages/ports are available, see the Downloads page.

Building

libsigrok

Installing the requirements:

$ pkg install git autoconf autoconf-archive automake libtool pkgconf glib libzip libftdi1 libcheck doxygen swig30 ruby python py27-numpy py27-setuptools py27-gobject3 openjdk-7.101.00_1,1

Building:

$ git clone git://sigrok.org/libsigrok
$ cd libsigrok
$ ./autogen.sh
$ ./configure --with-jni-include-path=/usr/local/openjdk7/include
$ make
$ sudo make install

libsigrokdecode

Installing the requirements:

$ pkg install python3

Building:

$ git clone git://sigrok.org/libsigrokdecode
$ cd libsigrokdecode
$ ./autogen.sh
$ ./configure
$ make
$ sudo make install

sigrok-firmware-fx2lafw

Installing the requirements:

$ pkg install sdcc

Building:

$ git clone git://sigrok.org/sigrok-firmware-fx2lafw
$ cd sigrok-firmware-fx2lafw
$ ./autogen.sh
$ ./configure
$ make
$ sudo make install

sigrok-cli

Building:

$ git clone git://sigrok.org/sigrok-cli
$ cd sigrok-cli
$ ./autogen.sh
$ ./configure
$ make
$ sudo make install

PulseView

Installing the requirements:

$ pkg install cmake qt4 qt4-qmake qt4-moc qt4-rcc qt4-uic boost-libs

Building:

$ git clone git://sigrok.org/pulseview
$ cd pulseview
$ cmake .
$ make
$ sudo make install

Hint: If something goes wrong, you can see what cmake is doing by running:

$ cmake VERBOSE=1