Bug 601 - FTDI USB->Serial device prevents libsigrok startup
Summary: FTDI USB->Serial device prevents libsigrok startup
Alias: None
Product: libsigrok
Classification: Unclassified
Component: Other (show other bugs)
Version: unreleased development snapshot
Hardware: x86 Windows
: Normal normal
Target Milestone: ---
Assignee: Nobody
Depends on:
Reported: 2015-06-30 12:32 CEST by Alan Bowman
Modified: 2020-06-01 15:00 CEST (History)
3 users (show)

Log of stderr in success case (32.63 KB, text/plain)
2015-07-01 09:59 CEST, Alan Bowman
Log in failure case (3.31 KB, text/plain)
2015-07-01 10:00 CEST, Alan Bowman

Note You need to log in before you can comment on or make changes to this bug.
Description Alan Bowman 2015-06-30 12:32:59 CEST
I downloaded the Pulseview nightly installer yesterday (29/6) and installed it on my Windows 7 64-bit machine.  When I try to start it, it crashes immediately with the message "pulseview.exe has stopped working".  The Fault Module Name in the details box says StackHash_0a9e.  This happens every time I try to open it.

This occurred before I had any logic analyzer devices installed on my PC, and also after I connected a Cypress-based device using fx2lafw.
Comment 1 Uwe Hermann 2015-06-30 13:40:04 CEST

the current nightly EXE seems to work fine for me (Win 7, 64bit). Can you check the FAQ here whether any of the items applies to your setup please?

Specifically the "error Oxc0150002" may be relevant (just a guess, though):


Were there any errors during the installation? Did you uninstall older versions of PulseView before this installation? Can you try running PulseView as administrator (shouldn't be needed, but it might be worth a test)?
Comment 2 Alan Bowman 2015-06-30 13:49:07 CEST
I had a look through the FAQ, and none seem to be relevant.  I have (several versions!) of the C++ redistributable package shown in Control Panel, so I assumed it's not related to that, and I don't recognise the error code.

I don't even get to the point of choosing a device (or selecting the demo device), so the other hints don't help.

I have installed and uninstalled this a couple of times, with the same results (both "fresh", and following an uninstallation of the previous attempt.  Looking at the date of the "nightly" packages in Jenkins, I think it was the some one both times.  I'm pretty sure there were no errors during installation.

Running as administrator gave exactly the same error.
Comment 3 Alan Bowman 2015-06-30 13:49:51 CEST
I just noticed - running "sigrok-cli.exe --scan" gives the exact same error.  Specifying the driver allows it to run way more successfully.
Comment 4 Alan Bowman 2015-06-30 14:34:35 CEST
This isn't a PulseView issue, but I'm not sure where it should be moved to.

I used Process Monitor (https://technet.microsoft.com/en-us/library/bb896645.aspx) to see what was going on before the crash, and it seemed to be scanning FTDI devices.

I have a number of FTDI USB->Serial devices plugged into my PC.  One in particular seems to cause the crash on startup.  It is an Abacus Optical Probe, FTDIBUS\COMPORT&VID_0403&PID_F458.  Unplugging this allows Pulseview to start correctly.
Comment 5 Uwe Hermann 2015-06-30 23:35:33 CEST
OK, that's some progress. Can you provide a log for the case with that FTDI device attached and one log with the device not being attached?

Please create the logs like this and attach them to the bug report:

 sigrok-cli --scan -l 5

Please also attach the output of "lsusb -v" (run as root) for that specific FTDI device. Thanks!

It might be something we can fix in one of the libsigrok drivers' scan() function, or maybe it's something libusb/libftdi related we cannot do much about, we'll have to see.
Comment 6 Alan Bowman 2015-07-01 09:59:47 CEST
Created attachment 137 [details]
Log of stderr in success case
Comment 7 Alan Bowman 2015-07-01 10:00:09 CEST
Created attachment 138 [details]
Log in failure case
Comment 8 Alan Bowman 2015-07-01 10:03:19 CEST
Attached are the logs in the success and failure cases (run from a Powershell prompt as Administrator).  I don't have lsusb option on my Windows machine - is there an equivalent?  I think the VID and PID (taken from the from the Device Manager) are VID_0403&PID_F458.
Comment 9 Uwe Hermann 2019-06-30 18:25:34 CEST
Hi, can you please retry the current sigrok-cli/PulseView nightly builds? We merged a bugfix recently (which fixes similar issues with other devices, e.g. #1370) which might have (indirectly) caused the issues you were seeing.
Comment 10 Gerhard Sittig 2020-06-01 15:00:53 CEST
Does it still reproduce with recent versions?
Is it another duplicate of bug 1031?