Bug 451 - PulseView cannot save *.sr files
: PulseView cannot save *.sr files
Status: RESOLVED FIXED
Product: PulseView
Classification: Unclassified
Component: File handling
: unreleased development snapshot
: All All
: High critical
: ---
Assigned To: Nobody
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-19 17:56 CEST by Uwe Hermann
Modified: 2014-11-22 21:22 CET (History)
1 user (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Uwe Hermann 2014-10-19 17:56:17 CEST
How to reproduce:

Start PulseView, acquire samples via some LA, click "Save As", use foo.sr as filename. There will be a "Failed to save session. Error while saving." popup window.

In the xterm:
  sr: session-file: Couldn't stat /home/uwe/foo.sr: No such file or directory

This seems to work file with sigrok-cli:

 $ sigrok-cli -d fx2lafw -c samplerate=1mhz --samples 1m -o foo.sr

(PulseView can open that foo.sr fine)


The same "cannot save" problem also happens if you open an existing *.sr file in PulseView and try to (re-)save it under a different name, for example.
Comment 1 Joel Holdsworth 2014-11-02 20:33:51 CET
seems to be a bug sigrok::Session::begin_save and sigrok::Session::append . append finds no file to append to
Comment 2 Joel Holdsworth 2014-11-22 10:51:14 CET
Now the save dialog just locks up indefinitely. No crash any more.
Comment 3 Uwe Hermann 2014-11-22 21:22:25 CET
Fixed in 7223eb629eb8eb3b03fa26b9f22770dd7f98c4d1 (implement file save via "srzip" output module) and e0e560a5b61ce41b1907d699911cae86a793d5d7.