Bump required Qt version to >= 5.3.
authorUwe Hermann <uwe@hermann-uwe.de>
Sat, 7 Sep 2019 17:25:36 +0000 (19:25 +0200)
committerUwe Hermann <uwe@hermann-uwe.de>
Sat, 7 Sep 2019 17:25:36 +0000 (19:25 +0200)
This is necessary since we now use QSignalBlocker, which was introduced
in Qt 5.3.

CMakeLists.txt
INSTALL

index 76e12935d1f788f1bd57fb4be05a3d113ace2dc2..9835094f9751627fd18bba876f2a46ed26f630cd 100644 (file)
@@ -101,14 +101,14 @@ pkg_check_modules(PKGDEPS REQUIRED ${PKGDEPS})
 
 set(CMAKE_AUTOMOC TRUE)
 
-find_package(Qt5 COMPONENTS Core Gui Widgets Svg REQUIRED)
+find_package(Qt5 5.3 COMPONENTS Core Gui Widgets Svg REQUIRED)
 
 if(WIN32)
        # MXE workaround: Use pkg-config to find Qt5 libs.
        # https://github.com/mxe/mxe/issues/1642
        # Not required (and doesn't work) on MSYS2.
        if(NOT DEFINED ENV{MSYSTEM})
-               pkg_check_modules(QT5ALL REQUIRED Qt5Widgets Qt5Gui Qt5Svg)
+               pkg_check_modules(QT5ALL REQUIRED Qt5Widgets>=5.3 Qt5Gui>=5.3 Qt5Svg>=5.3)
        endif()
 endif()
 
diff --git a/INSTALL b/INSTALL
index aba3cce7c21bb1097475ee0b35ef0fd65e92bc4e..dce8eb64142f1d19bc6b024311cd8afafb18c2ea 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -16,7 +16,7 @@ Requirements
  - libglib >= 2.28.0
  - glibmm-2.4 (>= 2.28.0)
  - gstreamermm-1.0 (>= 1.8.0)
- - Qt5 (including the following components):
+ - Qt5 (>= 5.3), including the following components:
     - Qt5Core, Qt5Gui, Qt5Widgets, Qt5Svg
  - libboost >= 1.55 (including the following libs):
     - libboost-system