]> sigrok.org Git - pulseview.git/blobdiff - test/CMakeLists.txt
Use boost::filesystem::path to get the filename from a path
[pulseview.git] / test / CMakeLists.txt
index 66dd7e51d3702721b9f757729dfea0fc8dc4dfda..98d8619c0b13c7515d23dbca751751e7b6d9d14b 100644 (file)
@@ -36,9 +36,9 @@ find_package(Threads)
 if(WIN32)
        # On Windows/MinGW we need to use 'thread_win32' instead of 'thread'.
        # The library is named libboost_thread_win32* (not libboost_thread*).
-       find_package(Boost 1.42 COMPONENTS system thread_win32 unit_test_framework REQUIRED)
+       find_package(Boost 1.42 COMPONENTS filesystem system thread_win32 unit_test_framework REQUIRED)
 else()
-       find_package(Boost 1.42 COMPONENTS system thread unit_test_framework REQUIRED)
+       find_package(Boost 1.42 COMPONENTS filesystem system thread unit_test_framework REQUIRED)
 endif()