]> sigrok.org Git - pulseview.git/blobdiff - test/CMakeLists.txt
pv::data::DecoderStack: Set _row for each annotation.
[pulseview.git] / test / CMakeLists.txt
index de2ef909cf86fdf7af5d07ebc1acd337a42b2b20..82e80a8af5d6535b31e0d73b8bb3f3f18d406370 100644 (file)
@@ -33,9 +33,16 @@ pkg_check_modules(PKGDEPS REQUIRED ${PKGDEPS})
 # This will set ${CMAKE_THREAD_LIBS_INIT} to the correct, OS-specific value.
 find_package(Threads)
 
-find_package(Boost 1.42 COMPONENTS system thread unit_test_framework REQUIRED)
+if(WIN32)
+       # On Windows/MinGW we need to use 'thread_win32' instead of 'thread'.
+       # The library is named libboost_thread_win32* (not libboost_thread*).
+       find_package(Boost 1.42 COMPONENTS system thread_win32 unit_test_framework REQUIRED)
+else()
+       find_package(Boost 1.42 COMPONENTS system thread unit_test_framework REQUIRED)
+endif()
+
 
-FIND_PROGRAM(QT_QMAKE_EXECUTABLE NAMES qmake4 qmake-qt4 qmake-mac)
+find_program(QT_QMAKE_EXECUTABLE NAMES qmake4 qmake-qt4 qmake-mac)
 find_package(Qt4 REQUIRED)
 
 set(pulseview_TEST_SOURCES
@@ -75,7 +82,7 @@ set(pulseview_TEST_SOURCES
        test.cpp
 )
 
-# This list includes only QObject derrived class headers
+# This list includes only QObject derived class headers.
 set(pulseview_TEST_HEADERS
        ${PROJECT_SOURCE_DIR}/pv/sigsession.h
        ${PROJECT_SOURCE_DIR}/pv/prop/int.h
@@ -124,7 +131,11 @@ if(ENABLE_DECODE)
        add_definitions(-DENABLE_DECODE)
 endif()
 
+# On MinGW we need to use static linking.
+if(NOT WIN32)
 add_definitions(-DBOOST_TEST_DYN_LINK)
+endif()
+
 add_definitions(${QT_DEFINITIONS})
 
 include_directories(
@@ -139,6 +150,11 @@ set(PULSEVIEW_LINK_LIBS
        ${QT_LIBRARIES}
 )
 
+if(WIN32)
+       # Workaround for a MinGW linking issue.
+       list(APPEND PULSEVIEW_LINK_LIBS "-llzma -llcms2")
+endif()
+
 add_executable(pulseview-test
        ${pulseview_TEST_SOURCES}
        ${pulseview_TEST_HEADERS_MOC}