]> sigrok.org Git - pulseview.git/blobdiff - manual/CMakeLists.txt
Installer: Add links to manual
[pulseview.git] / manual / CMakeLists.txt
index 25a26e995a22b050ec70893fde49cf8660f9fbd6..c425f36b3bdd7eb3cf246b6c593a97218a8edcfd 100644 (file)
 ## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 ##
 
+cmake_minimum_required(VERSION 2.8.12)
+
+# External dependencies, required and optional tools.
 find_program(ASCIIDOCTOR_EXECUTABLE NAMES asciidoctor)
 find_program(ASCIIDOCTOR_PDF_EXECUTABLE NAMES asciidoctor-pdf)
 
+# Tunables.
 set(STYLES_DIR "asciidoctor-stylesheet-factory/stylesheets")
 set(STYLE_SHEET "readthedocs.css")
-set(MANUAL_SRC "${CMAKE_CURRENT_SOURCE_DIR}/pulseview_manual.txt")
-set(MANUAL_OUT_HTML "${CMAKE_CURRENT_BINARY_DIR}/pulseview_manual.html")
-set(MANUAL_OUT_PDF "${CMAKE_CURRENT_BINARY_DIR}/pulseview_manual.pdf")
 
+# Input files.
+set(MANUAL_SRC "${CMAKE_CURRENT_SOURCE_DIR}/manual.txt")
+
+# Output files, conversion results.
+set(MANUAL_OUT_HTML "${CMAKE_CURRENT_BINARY_DIR}/manual.html")
+set(MANUAL_OUT_PDF "${CMAKE_CURRENT_BINARY_DIR}/manual.pdf")
+
+# Manual related make(1) targets.
 add_custom_target(manual-html
        COMMAND ${ASCIIDOCTOR_EXECUTABLE}
                -a stylesheet=${STYLE_SHEET}
@@ -53,7 +62,7 @@ if (ASCIIDOCTOR_PDF_EXECUTABLE)
 else ()
        add_custom_target(manual-pdf
                COMMAND ${CMAKE_COMMAND} -E echo
-                       "asciidoctor-pdf executable is missing, NOT generating HTML output"
+                       "asciidoctor-pdf executable is missing, NOT generating PDF output"
                DEPENDS ${MANUAL_SRC}
                WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
        )