Lower glib-2.0 requirement to 2.24.0.