Bump libsigrok (optional) dependency to 0.3.0.
authorUwe Hermann <uwe@hermann-uwe.de>
Tue, 6 May 2014 21:06:57 +0000 (23:06 +0200)
committerUwe Hermann <uwe@hermann-uwe.de>
Tue, 6 May 2014 21:07:15 +0000 (23:07 +0200)
README
configure.ac

diff --git a/README b/README
index 82c784905672959f3a32484e93836e3d78508dcd..fa30ef066a30573f9b0636ff16a2eaf0fad7a909 100644 (file)
--- a/README
+++ b/README
@@ -37,7 +37,7 @@ Requirements
  - libglib >= 2.24.0
  - Python >= 3.2
  - check >= 0.9.4 (optional, only needed to run unit tests)
  - libglib >= 2.24.0
  - Python >= 3.2
  - check >= 0.9.4 (optional, only needed to run unit tests)
- - libsigrok >= 0.2.0 (optional, only needed for the developer PD tests)
+ - libsigrok >= 0.3.0 (optional, only needed for the developer PD tests)
  - python3-coverage (optional, only needed for the developer PD tests)
 
 
  - python3-coverage (optional, only needed for the developer PD tests)
 
 
index c27376fd33339dcbb06628d0bda94fa7eae19156..972ceac7eaa4b1fe6ca48a9e042ddde4bbc1e153 100644 (file)
@@ -133,7 +133,7 @@ AM_CONDITIONAL(HAVE_CHECK, test x"$have_check" = "xyes")
 
 # libsigrok is optional (only used for the protocol decoder test framework).
 # Disable if not found.
 
 # libsigrok is optional (only used for the protocol decoder test framework).
 # Disable if not found.
-PKG_CHECK_MODULES([libsigrok], [libsigrok >= 0.2.0],
+PKG_CHECK_MODULES([libsigrok], [libsigrok >= 0.3.0],
        [LIBSIGROK_CFLAGS="$libsigrok_CFLAGS"; LIBSIGROK_LIBS="$libsigrok_LIBS"],
        [build_runtc="no"])
 AC_SUBST([LIBSIGROK_CFLAGS])
        [LIBSIGROK_CFLAGS="$libsigrok_CFLAGS"; LIBSIGROK_LIBS="$libsigrok_LIBS"],
        [build_runtc="no"])
 AC_SUBST([LIBSIGROK_CFLAGS])
@@ -182,7 +182,7 @@ else
 fi
 
 # Note: This only works for libs with pkg-config integration.
 fi
 
 # Note: This only works for libs with pkg-config integration.
-for lib in "glib-2.0 >= 2.24.0" "check >= 0.9.4" "libsigrok >= 0.2.0"; do
+for lib in "glib-2.0 >= 2.24.0" "check >= 0.9.4" "libsigrok >= 0.3.0"; do
        optional="OPTIONAL"
        if test "x$lib" = "xglib-2.0 >= 2.24.0"; then optional="REQUIRED"; fi
        if `$PKG_CONFIG --exists $lib`; then
        optional="OPTIONAL"
        if test "x$lib" = "xglib-2.0 >= 2.24.0"; then optional="REQUIRED"; fi
        if `$PKG_CONFIG --exists $lib`; then