Lower glib-2.0 requirement to 2.24.0.
authorUwe Hermann <uwe@hermann-uwe.de>
Sat, 19 Jan 2013 15:38:46 +0000 (16:38 +0100)
committerUwe Hermann <uwe@hermann-uwe.de>
Sat, 19 Jan 2013 15:38:46 +0000 (16:38 +0100)
We don't use any of the recent glib features in libsigrokdecode, it
compiles fine with 2.24.x.

README
configure.ac

diff --git a/README b/README
index ee34529094842e52b3399903393ef007d7214ab5..0a9493398feb6ad90be3613ac883836fc3bb29c5 100644 (file)
--- a/README
+++ b/README
@@ -34,7 +34,7 @@ Requirements
  - automake >= 1.11
  - libtool
  - pkg-config >= 0.22
- - libglib >= 2.28.0
+ - libglib >= 2.24.0
  - Python >= 3.0
 
 
index e024014668a7952a763692f8aef34fc36e929971..444b631f806eb3d745c2926d0b35776dd525fc62 100644 (file)
@@ -80,7 +80,7 @@ AC_SUBST(SRD_LIB_LDFLAGS)
 # libglib-2.0 is always needed.
 # Note: glib-2.0 is part of the libsigrokdecode API
 # (hard pkg-config requirement).
-AM_PATH_GLIB_2_0([2.28.0],
+AM_PATH_GLIB_2_0([2.24.0],
         [CFLAGS="$CFLAGS $GLIB_CFLAGS"; LIBS="$LIBS $GLIB_LIBS"])
 
 # Python support. We require at least Python >= 3.0.