Mark all stacked decoders as being PD API version 3.
authorUwe Hermann <uwe@hermann-uwe.de>
Fri, 16 Jun 2017 14:27:08 +0000 (16:27 +0200)
committerUwe Hermann <uwe@hermann-uwe.de>
Fri, 16 Jun 2017 14:27:08 +0000 (16:27 +0200)
commitb197383cfb39b39ff04644855eef57f5d3c18bc1
tree2e83d21a65d6a8c3f5ad9ac3c3ce3ebe289dfa8e
parent6eb8f524817b3893632d9a651852f1fefe6fcd18
Mark all stacked decoders as being PD API version 3.

This is not really relevant for stacked PDs currently (they can be used
unmodified with either PDv2 or PDv3 low-level decoders), but it'll allow
us to drop PDv2 support completely.
36 files changed:
decoders/ade77xx/pd.py
decoders/adf435x/pd.py
decoders/adns5020/pd.py
decoders/arm_etmv3/pd.py
decoders/arm_itm/pd.py
decoders/arm_tpiu/pd.py
decoders/avr_isp/pd.py
decoders/ds1307/pd.py
decoders/ds28ea00/pd.py
decoders/edid/pd.py
decoders/eeprom24xx/pd.py
decoders/eeprom93xx/pd.py
decoders/i2cdemux/pd.py
decoders/i2cfilter/pd.py
decoders/jtag_stm32/pd.py
decoders/lm75/pd.py
decoders/max7219/pd.py
decoders/midi/pd.py
decoders/mlx90614/pd.py
decoders/modbus/pd.py
decoders/mrf24j40/pd.py
decoders/mxc6225xu/pd.py
decoders/nrf24l01/pd.py
decoders/nunchuk/pd.py
decoders/onewire_network/pd.py
decoders/pan1321/pd.py
decoders/rfm12/pd.py
decoders/rgb_led_spi/pd.py
decoders/rtc8564/pd.py
decoders/sdcard_spi/pd.py
decoders/spiflash/pd.py
decoders/ssi32/pd.py
decoders/tca6408a/pd.py
decoders/usb_packet/pd.py
decoders/usb_request/pd.py
decoders/xfp/pd.py