]> sigrok.org Git - libsigrokdecode.git/blobdiff - tests/Makefile.am
runtc: Make sure to test this set of decoders, not the installed ones.
[libsigrokdecode.git] / tests / Makefile.am
index 7841f055c09bb3dd05af7f4e620cc7d2cab92121..5739a035c7730a944eaa4f44ba2563d26f139c1c 100644 (file)
@@ -41,6 +41,7 @@ endif
 if HAVE_LIBSIGROK
 bin_PROGRAMS = runtc
 runtc_SOURCES = runtc.c
-runtc_CPPFLAGS = $(CPPFLAGS_PYTHON) $(LIBSIGROK_CFLAGS)
+runtc_CPPFLAGS = $(CPPFLAGS_PYTHON) $(LIBSIGROK_CFLAGS) \
+       -DDECODERS_DIR='"$(abs_top_builddir)/decoders"'
 runtc_LDFLAGS = $(LIBSIGROK_LIBS) -L$(top_builddir) -lsigrokdecode
 endif