edid: Shorten two code snippets.
[libsigrokdecode.git] / configure.ac
index b08eab71856dbf74fd62656e8eadd3fb2da23b52..772b984ed6b8cdcda9c496e5443b4fb10c3780e3 100644 (file)
@@ -21,7 +21,7 @@
 AC_PREREQ([2.63])
 
 # libsigrokdecode package version number (NOT the same as shared lib version!).
-AC_INIT([libsigrokdecode], [0.4.0],
+AC_INIT([libsigrokdecode], [0.6.0],
        [sigrok-devel@lists.sourceforge.net], [libsigrokdecode],
        [http://www.sigrok.org])
 AC_CONFIG_MACRO_DIR([m4])
@@ -63,10 +63,14 @@ SR_PKG_VERSION_SET([SRD_PACKAGE_VERSION], [AC_PACKAGE_VERSION])
 # The algorithm for determining which number to change (and how) is nontrivial!
 # http://www.gnu.org/software/libtool/manual/libtool.html#Updating-version-info
 # Format: current:revision:age.
-SR_LIB_VERSION_SET([SRD_LIB_VERSION], [3:0:0])
+SR_LIB_VERSION_SET([SRD_LIB_VERSION], [4:0:0])
 
 AM_CONDITIONAL([WIN32], [test -z "${host_os##mingw*}" || test -z "${host_os##cygwin*}"])
 
+# Initialize pkg-config.
+# We require at least 0.22, as "Requires.private" behaviour changed there.
+PKG_PROG_PKG_CONFIG
+
 ############################
 ##  Package dependencies  ##
 ############################
@@ -86,14 +90,14 @@ SR_PKG_CHECK_SUMMARY([srd_pkglibs_summary])
 
 # Python 3 is always needed.
 SR_PKG_CHECK([python3], [SRD_PKGLIBS],
-       [python3 >= 3.2], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2])
+       [python3 >= 3.2], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2])
 AS_IF([test "x$sr_have_python3" = xno],
        [AC_MSG_ERROR([Cannot find Python 3 development headers.])])
 
 # We also need to find the name of the python3 executable (for 'make install').
 # Some OSes call this python3, some call it python3.2, etc. etc.
 AC_ARG_VAR([PYTHON3], [Python 3 interpreter])
-AC_CHECK_PROGS([PYTHON3], [python3.5 python3.4 python3.3 python3.2 python3])
+AC_CHECK_PROGS([PYTHON3], [python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3])
 AS_IF([test "x$PYTHON3" = x],
        [AC_MSG_ERROR([Cannot find Python 3 interpreter.])])
 
@@ -115,7 +119,7 @@ SR_CHECK_COMPILE_FLAGS([SRD_EXTRA_CFLAGS], [C99], [-std=c99 -c99 -AC99 -qlanglvl
 SR_CHECK_COMPILE_FLAGS([SRD_EXTRA_CFLAGS], [visibility], [-fvisibility=hidden])
 
 # Select suitable compiler warning flags.
-SR_ARG_ENABLE_WARNINGS([SRD_WFLAGS], [-Wall], [-Wall -Wextra -Wmissing-prototypes])
+SR_ARG_ENABLE_WARNINGS([SRD_WFLAGS], [-Wall], [-Wall -Wextra -Wmissing-prototypes -Wshadow -Wformat=2 -Wno-format-nonliteral -Wfloat-equal])
 
 # Link against libm, this is required (among other things) by Python.
 SRD_EXTRA_LIBS=
@@ -123,6 +127,8 @@ SR_SEARCH_LIBS([SRD_EXTRA_LIBS], [pow], [m])
 
 AC_SYS_LARGEFILE
 
+AC_C_BIGENDIAN
+
 ##############################
 ##  Finalize configuration  ##
 ##############################
@@ -131,11 +137,14 @@ AC_SUBST([SRD_PKGLIBS])
 
 # Retrieve the compile and link flags for all modules combined.
 # Also, bail out at this point if any module dependency is not met.
-PKG_CHECK_MODULES([LIBSIGROKDECODE], [glib-2.0 >= 2.28.0 $SRD_PKGLIBS])
+PKG_CHECK_MODULES([LIBSIGROKDECODE], [glib-2.0 >= 2.34 $SRD_PKGLIBS])
 PKG_CHECK_MODULES([TESTS], [$SRD_PKGLIBS_TESTS glib-2.0 $SRD_PKGLIBS])
 
 srd_glib_version=`$PKG_CONFIG --modversion glib-2.0 2>&AS_MESSAGE_LOG_FD`
 
+AC_DEFINE_UNQUOTED([CONF_HOST], ["$host"],
+        [The canonical host libsigrokdecode will run on.])
+
 AC_CONFIG_FILES([Makefile libsigrokdecode.pc])
 
 AC_OUTPUT
@@ -148,6 +157,7 @@ libsigrokdecode configuration summary:
  - Prefix.......................... $prefix
  - Building on..................... $build
  - Building for.................... $host
+ - Building shared / static........ $enable_shared / $enable_static
 
 Compile configuration:
  - C compiler...................... $CC
@@ -155,9 +165,10 @@ Compile configuration:
  - C compiler flags................ $CFLAGS
  - Additional C compiler flags..... $SRD_EXTRA_CFLAGS
  - C compiler warnings............. $SRD_WFLAGS
+ - Linker flags.................... $LDFLAGS
 
 Detected libraries (required):
- - glib-2.0 >= 2.28.0.............. $srd_glib_version
+ - glib-2.0 >= 2.34................ $srd_glib_version
 $srd_pkglibs_summary
 Detected libraries (optional):
 $srd_pkglibs_opt_summary