Bug 1319 - PulseView closes on "scanning for axis-sigma" window
Summary: PulseView closes on "scanning for axis-sigma" window
Alias: None
Product: PulseView
Classification: Unclassified
Component: Other (show other bugs)
Version: unreleased development snapshot
Hardware: All All
: Normal normal
Target Milestone: ---
Assignee: Nobody
Depends on:
Reported: 2018-11-06 16:11 CET by paul
Modified: 2018-11-07 10:14 CET (History)
2 users (show)


Note You need to log in before you can comment on or make changes to this bug.
Description paul 2018-11-06 16:11:56 CET
I had PulseView working, but now every time I open it the app almost immediately closes. No crash, no error message, the scanning window just closes on the "scanning for axis-sigma" message and the task ends.

I tried 0.4.1 release and the nightly, both x64 and x86.

Windows 10 Pro x64. Tried removing all USB devices except for mouse and keyboard.
Comment 1 Soeren Apel 2018-11-06 16:22:18 CET
Are you using an HP laptop with a thunderbolt dock?
Comment 2 paul 2018-11-06 17:21:48 CET
I am using a Dell laptop with Thunderbolt dock. I sense you have encountered this before.
Comment 3 Soeren Apel 2018-11-06 18:12:46 CET
Yeah, PV shows the same behavior for me when the dock is attached. Disconnecting the dock allows PV to start normally.

If you need the dock, you can work around this issue by starting pulseview with the -D parameter (which prevents device scan on startup, so you'll need to manually scan for the device you want to use afterwards).

I didn't see anything obvious about the USB devices that show up when the dock is attached, so a gdb trace is required. However, I'm a linux guy, so my motivation to work on Windows is... limited.
Comment 4 paul 2018-11-07 10:14:14 CET
Thanks. It's randomly decided to work again now. Next time it happens I will try the -D option.

If I find time I'll try to compile it and see if I can do any debugging. Now you have narrowed it down a bit I might stand a chance of finding the issue quickly.