Bug 1282 - slow UI response at certain zoom levels, touchpad control
Summary: slow UI response at certain zoom levels, touchpad control
Status: RESOLVED DUPLICATE of bug 1056
Alias: None
Product: PulseView
Classification: Unclassified
Component: UI (show other bugs)
Version: unreleased development snapshot
Hardware: x86 Mac OS X
: Normal normal
Target Milestone: ---
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-18 13:09 CEST by zfefm
Modified: 2018-09-28 19:40 CEST (History)
2 users (show)



Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zfefm 2018-09-18 13:09:38 CEST
I use the "demo device" of the current PulseView nightly MAC (0.5.0-git-fa7359b) with OS 10.9.5 on a quite fast and well equipped MAC.
I fund a few issues:

I pressed "Run" and recoded about 2 seconds with the default settings.
Then when I hit "+" several times to zoom in (to about 150ms per window width) pulseview essentially gets unreponsive for minutes/ever (spinning beachball of death - 100% CPU load - about all 20-30s pulseview reacts for a short moment to commands).

If you zoom in further, to about 20ms per window with, pulseview becomes eventually responsive again.


If you use the trackpad of the MAC for scrolling (at least that would be the expected action on a MAC) over the signals, some wild zoom in-out is triggered. This is especially annoying due to the freeze issue above.


Next I would like to know if I can use the analog channels with the protocol decoders in general (i.e. of a Siglent SDS2000X, for which the LA channels are not accessible for sigrok)? With the demo device this is not possible. For some decoders, such as Morse, it is explicitly mentioned that this should work (but does not with the demo device).
Comment 1 Gerhard Sittig 2018-09-18 17:47:53 CEST
Have changed the Product and component to Pulseview and UI, since the report 
is about zoom during inspection of previously acquired data, the acquisition 
device does not matter here (no longer does after acquisition is done).

Please don't mix unrelated subjects in a single report.  This is the bug 
tracker, not a support forum.  You need to convert analog channels to logic 
before you can apply decoders to the resulting logic channels.  See the doc 
about the A2L conversion feature (it's a Pulseview only feature, not available 
in the CLI application).  This shall answer your question, and leave the 
remainder of the report to the GUI and zooming.
Comment 2 Soeren Apel 2018-09-19 18:52:28 CEST
Thanks for the report, this is most likely a duplicate of #1056, so I'm closing this one.
Comment 3 Soeren Apel 2018-09-19 18:52:42 CEST

*** This bug has been marked as a duplicate of bug 1056 ***
Comment 4 zfefm 2018-09-19 19:15:58 CEST
I agree that the random behavior with the trackpad bug sounds like a duplicate of the linked bug. However I have disabled all trackpad events except secondary click. The zooming activity is nevertheless triggered by mere scrolling.

The behavior reported in the first part, the zoom-in-freeze, seems to be something different. Knowing of the problems caused by scrolling, I avoided scrolling and only hit the "+ Icon" and got the freeze. And the freeze appears only at a certain zoom level.
Comment 5 Soeren Apel 2018-09-19 19:21:47 CEST
Hm, no idea what's going on there. Can you make a video, maybe?
Comment 6 zfefm 2018-09-28 19:40:53 CEST
It seems that the issue is MacBook related, not necessarily (only) trackpad related.

I tried with a desktop Mac, there Pulseview runs fluent.

On the Macbook the behavior depends on the setup:

I tried the MacBook with an old Mouse attached (so not touching the trackpad). Zooming in (clicking on "+") results after a few clicks in 100% CPU load and the beach ball of death, but only for a few seconds - definitely shorter as when I do it with the trackpad.

With the trackpad I tried to make a video using the Quicktime feature for that. I also got the 100% CPU load and the beach ball of death but not as long as if I did not try to make the Quicktime video.

I need to find a camera to make a video of the worst effect.

I do not think the problem related to the resources of the Mackbook it usually outperforms the used desktop Mac. It is a MacBook Pro late 2013 with an i7 4850HQ CPU, 16GB RAM, SSD, GeForce GT 750M.