Bug 1126 - Problem to compile pulseview android and to run on huawei mediapad10
Summary: Problem to compile pulseview android and to run on huawei mediapad10
Alias: None
Product: PulseView
Classification: Unclassified
Component: Portability (show other bugs)
Version: unreleased development snapshot
Hardware: All All
: Normal normal
Target Milestone: ---
Assignee: Nobody
Depends on:
Reported: 2018-02-25 15:11 CET by rkardell
Modified: 2018-02-26 23:33 CET (History)
0 users

Build error log (6.14 KB, text/plain)
2018-02-25 15:11 CET, rkardell
Compile error log (320.83 KB, text/plain)
2018-02-26 23:33 CET, rkardell

Note You need to log in before you can comment on or make changes to this bug.
Description rkardell 2018-02-25 15:11:05 CET
Created attachment 388 [details]
Build error log

I tried pulseview nightly build 180219 on android with different results

Lenovo IdeaPad A7-40 A3500-FL + LHT00SU1
Works ok

Huawei MediaPad10 Link+ S10-231w + LHT00SU1
Starts, shows black screen with pulseview logo+text in upper left corner, no scan, then exits from pulseview after app. 1-2 sec.

In order to find the problem I tried to compile pulseview:

Ubuntu Mate 16.04.2
Added cmake and default-jdk

I installed pulseview according to https://sigrok.org/wiki/Android

./sigrok-cross-android prepare gave no errors

When running ./sigrok-cross-android I got error messages found in attachment:

(complete log available)
Comment 1 rkardell 2018-02-26 23:33:22 CET
Created attachment 391 [details]
Compile error log