Bug 1063 - Unable to connect DSLogic Basic
Summary: Unable to connect DSLogic Basic
Status: RESOLVED DUPLICATE of bug 1049
Alias: None
Product: libsigrok
Classification: Unclassified
Component: Driver: dreamsourcelab-dslogic (show other bugs)
Version: unreleased development snapshot
Hardware: x86 Linux
: Normal normal
Target Milestone: ---
Assignee: Nobody
URL:
Depends on:
Blocks:
 
Reported: 2017-11-01 22:51 CET by Wayne
Modified: 2017-11-02 01:51 CET (History)
1 user (show)



Attachments
Full pulseview log (16.06 KB, text/plain)
2017-11-01 22:51 CET, Wayne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wayne 2017-11-01 22:51:27 CET
Created attachment 347 [details]
Full pulseview log

Quite likely a duplication of bug #1049 but on linux also.

Unable to connect to DSLogic Basic when using PulseView on Ubuntu 16.04. Using latest git versions of libsigrok, pulseview, libsigrok-utils, etc.

Latest firmware versions downloaded and renamed using sigrok-fwextract-dreamsourcelab-dslogic from libsigrok-utils. Here is the relevant output of pulseview with log level set to 5; initial start then attempted to connect manually a couple of times (full log attached):

    sr: [00:02.987300] resource: SIGROK_FIRMWARE_DIR environment variable not set, ignoring.
    sr: [00:03.018561] resource: Opened '/home/wayne/.local/share/sigrok-firmware/dreamsourcelab-dslogic-basic-fx2.fw'.
    sr: [00:03.024511] ezusb: Uploading firmware 'dreamsourcelab-dslogic-basic-fx2.fw'.
    sr: [00:03.024884] ezusb: Uploaded 4096 bytes.
    sr: [00:03.025183] ezusb: Uploaded 4024 bytes.
    sr: [00:03.025189] ezusb: Firmware upload done.
    sr: [00:03.025191] ezusb: setting CPU reset mode off...
    sr: [00:03.025234] hwdriver: Scan found 1 devices (dreamsourcelab-dslogic).
    sr: [00:03.808238] device: dreamsourcelab-dslogic: Opening device instance.
    sr: [00:03.808258] dreamsourcelab-dslogic: Waiting for device to reset.
    sr: [00:04.208519] dreamsourcelab-dslogic: Waited 1183ms.
    sr: [00:04.308687] dreamsourcelab-dslogic: Waited 1283ms.
    sr: [00:04.408857] dreamsourcelab-dslogic: Waited 1383ms.
    sr: [00:04.509027] dreamsourcelab-dslogic: Waited 1483ms.
    sr: [00:04.609180] dreamsourcelab-dslogic: Waited 1583ms.
    sr: [00:04.709363] dreamsourcelab-dslogic: Waited 1684ms.
    sr: [00:04.809554] dreamsourcelab-dslogic: Waited 1784ms.
    sr: [00:04.809798] dreamsourcelab-dslogic: Expected firmware version 1.x, 
got 160.0.
    sr: [00:04.909928] dreamsourcelab-dslogic: Waited 1884ms.
    sr: [00:04.910148] dreamsourcelab-dslogic: Expected firmware version 1.x, got 160.0.
    sr: [00:05.010256] dreamsourcelab-dslogic: Waited 1985ms.
    sr: [00:05.010509] dreamsourcelab-dslogic: Expected firmware version 1.x, got 160.0.
    sr: [00:05.110671] dreamsourcelab-dslogic: Waited 2085ms.
    sr: [00:05.111040] dreamsourcelab-dslogic: Expected firmware version 1.x, 
got 160.0.
    sr: [00:05.211196] dreamsourcelab-dslogic: Waited 2185ms.
    sr: [00:05.211449] dreamsourcelab-dslogic: Expected firmware version 1.x, got 160.0.
    sr: [00:05.311583] dreamsourcelab-dslogic: Waited 2286ms.
    sr: [00:05.311822] dreamsourcelab-dslogic: Expected firmware version 1.x, got 160.0.
    sr: [00:05.411957] dreamsourcelab-dslogic: Waited 2386ms.
    sr: [00:05.412195] dreamsourcelab-dslogic: Expected firmware version 1.x, got 160.0.
    sr: [00:05.512329] dreamsourcelab-dslogic: Waited 2487ms.
    sr: [00:05.512566] dreamsourcelab-dslogic: Expected firmware version 1.x, 
got 160.0.
    sr: [00:05.612703] dreamsourcelab-dslogic: Waited 2587ms.
    sr: [00:05.612972] dreamsourcelab-dslogic: Expected firmware version 1.x, got 160.0.
    sr: [00:05.713107] dreamsourcelab-dslogic: Waited 2687ms.
    sr: [00:05.713351] dreamsourcelab-dslogic: Expected firmware version 1.x, got 160.0.
    sr: [00:05.813488] dreamsourcelab-dslogic: Waited 2788ms.
    sr: [00:05.813746] dreamsourcelab-dslogic: Expected firmware version 1.x, got 160.0.
    sr: [00:05.913847] dreamsourcelab-dslogic: Waited 2888ms.
    sr: [00:05.914083] dreamsourcelab-dslogic: Expected firmware version 1.x, got 160.0.
    sr: [00:06.014216] dreamsourcelab-dslogic: Waited 2988ms.
    sr: [00:06.014423] dreamsourcelab-dslogic: Expected firmware version 1.x, 
got 160.0.
    sr: [00:06.114555] dreamsourcelab-dslogic: Waited 3089ms.
    sr: [00:06.114577] dreamsourcelab-dslogic: Device failed to renumerate.
    sr: [00:20.509481] ezusb: uploading firmware to device on 2.53
    sr: [00:20.509578] ezusb: setting CPU reset mode on...
    sr: [00:20.509650] resource: SIGROK_FIRMWARE_DIR environment variable not set, ignoring.
    sr: [00:20.509701] resource: Opened '/home/wayne/.local/share/sigrok-
firmware/dreamsourcelab-dslogic-basic-fx2.fw'.
    sr: [00:20.509770] ezusb: Uploading firmware 'dreamsourcelab-dslogic-basic-fx2.fw'.
    sr: [00:20.510073] ezusb: Uploaded 4096 bytes.
    sr: [00:20.510384] ezusb: Uploaded 4024 bytes.
    sr: [00:20.510406] ezusb: Firmware upload done.
    sr: [00:20.510418] ezusb: setting CPU reset mode off...
    sr: [00:20.510492] hwdriver: Scan found 1 devices (dreamsourcelab-dslogic).
    sr: [00:23.145690] device: dreamsourcelab-dslogic: Opening device instance.
    sr: [00:23.145716] dreamsourcelab-dslogic: Waiting for device to reset.
    sr: [00:23.446052] dreamsourcelab-dslogic: Expected firmware version 1.x, got 0.44.
    sr: [00:23.546162] dreamsourcelab-dslogic: Waited 3035ms.
    sr: [00:23.546189] dreamsourcelab-dslogic: Device failed to renumerate.
    sr: [00:46.157764] ezusb: uploading firmware to device on 2.54
    sr: [00:46.157839] ezusb: setting CPU reset mode on...
    sr: [00:46.157886] resource: SIGROK_FIRMWARE_DIR environment variable not set, ignoring.
    sr: [00:46.157910] resource: Opened '/home/wayne/.local/share/sigrok-firmware/dreamsourcelab-dslogic-basic-fx2.fw'.
    sr: [00:46.157931] ezusb: Uploading firmware 'dreamsourcelab-dslogic-basic-fx2.fw'.
    sr: [00:46.158194] ezusb: Uploaded 4096 bytes.
    sr: [00:46.158465] ezusb: Uploaded 4024 bytes.
    sr: [00:46.158475] ezusb: Firmware upload done.
    sr: [00:46.158482] ezusb: setting CPU reset mode off...
    sr: [00:46.158520] hwdriver: Scan found 1 devices (dreamsourcelab-dslogic).
    sr: [00:47.717295] device: dreamsourcelab-dslogic: Opening device instance.
    sr: [00:47.717328] dreamsourcelab-dslogic: Waiting for device to reset.
    sr: [00:48.017732] dreamsourcelab-dslogic: Expected firmware version 1.x, 
got 16.37.
    sr: [00:48.117879] dreamsourcelab-dslogic: Waited 1959ms.
    sr: [00:48.118060] dreamsourcelab-dslogic: Expected firmware version 1.x, got 16.37.
    sr: [00:48.218177] dreamsourcelab-dslogic: Waited 2059ms.
    sr: [00:48.218405] dreamsourcelab-dslogic: Expected firmware version 1.x, got 16.37.
    sr: [00:48.318543] dreamsourcelab-dslogic: Waited 2160ms.
    sr: [00:48.318832] dreamsourcelab-dslogic: Expected firmware version 1.x, got 16.37.
    sr: [00:48.418963] dreamsourcelab-dslogic: Waited 2260ms.
    sr: [00:48.419315] dreamsourcelab-dslogic: Expected firmware version 1.x, got 16.37.
    sr: [00:48.519464] dreamsourcelab-dslogic: Waited 2360ms.
    sr: [00:48.519629] dreamsourcelab-dslogic: Expected firmware version 1.x, got 16.37.
    sr: [00:48.619759] dreamsourcelab-dslogic: Waited 2461ms.
    sr: [00:48.619987] dreamsourcelab-dslogic: Expected firmware version 1.x, got 16.37.
    sr: [00:48.720117] dreamsourcelab-dslogic: Waited 2561ms.
    sr: [00:48.720362] dreamsourcelab-dslogic: Expected firmware version 1.x, got 16.37.
    sr: [00:48.820480] dreamsourcelab-dslogic: Waited 2661ms.
    sr: [00:48.820832] dreamsourcelab-dslogic: Expected firmware version 1.x, got 16.37.
    sr: [00:48.920975] dreamsourcelab-dslogic: Waited 2762ms.
    sr: [00:48.921229] dreamsourcelab-dslogic: Expected firmware version 1.x, got 16.37.
    sr: [00:49.021312] dreamsourcelab-dslogic: Waited 2862ms.
    sr: [00:49.021559] dreamsourcelab-dslogic: Expected firmware version 1.x, got 16.37.
    sr: [00:49.121687] dreamsourcelab-dslogic: Waited 2963ms.
    sr: [00:49.121970] dreamsourcelab-dslogic: Expected firmware version 1.x, got 16.37.
    sr: [00:49.222103] dreamsourcelab-dslogic: Waited 3063ms.
    sr: [00:49.222125] dreamsourcelab-dslogic: Device failed to renumerate.

Firmware appears to load however pulseview cannot connect due to the reported firmware not matching the expected response. Reported firmware number changes with each attempt to connect, although 160.0 on the first attempt does seem to be quite consistent.
There is no change to lsusb pre or post firmware upload.

Cheers
Wayne
Comment 1 Uwe Hermann 2017-11-02 01:49:13 CET
Yup, it's a duplicate of #1049, marking as such. I can reproduce the issue on Linux and Windows with DSLogic (original) and Basic and Pro as well. At the moment I seem to be getting "Expected firmware version 1.x, got 0.0." consistently. Could be something timing-related, or some upstream change we have yet to identify and account for.

Anyway, we should continue this at #1049.

*** This bug has been marked as a duplicate of bug 1049 ***
Comment 2 Uwe Hermann 2017-11-02 01:51:08 CET
Correction, when I said "Pro" I meant "Plus".