Bug 1152

Summary: No device in PulseView : Saleae clone FX2 based logic analyser not recognised
Product: libsigrok Reporter: Nicolas <niseclo>
Component: Driver: fx2lafwAssignee: Nobody <nobody>
Severity: normal CC: just_me_myst, soeren, stefan.bruens
Priority: Normal    
Version: unreleased development snapshot   
Target Milestone: ---   
Hardware: ARM   
OS: Linux   

Description Nicolas 2018-04-07 00:17:09 CEST
I am running pulseview (and other sigrok software) on a raspberry Pi 3 with uptodate Raspbian.
I have built all software the same day I report this bug (6th April 2018) following Linux Build page for Debian based system.
All the builds went pretty well and I can open Pulseview, and it works with Demo device.

But after hours of searching and trying things, I cannot have Pulseview to detect my Salae clone type 8Ch logic analyser (this model : https://sigrok.org/wiki/MCU123_Saleae_Logic_clone )

When I do a
sigrok-cli --scan
I get : 
sr: fx2lafw: Failed to open potential device with VID:PID 0925:3881: LIBUSB_ERROR_ACCESS.
The following devices were found:
demo - Demo device with 12 channels: D0 D1 D2 D3 D4 D5 D6 D7 A0 A1 A2 A3

I have downloaded fx2lafw firmware from http://sigrok.org/download/binary/sigrok-firmware-fx2lafw/
and I copied the content to /usr/share/sigrok-firmware  but this didn't solve the bug.

Also, here is lsusb result for the Logic Analyzer :
Bus 001 Device 006: ID 0925:3881 Lakeview Research Saleae Logic

Having not found any solution in google, i report a possible bug.

Do you have a solution ?

Comment 1 Nicolas 2018-04-07 00:25:05 CEST
forgot to mention that I changed the USB cable, but the bug remained and lsusb and other messages remained the same.
Comment 2 Stefan BrĂ¼ns 2018-04-07 03:02:21 CEST
You probably failed to install the udev rules to the correct location.
Comment 3 Soeren Apel 2018-04-07 07:49:45 CEST
To check if it's udev, you can try running PV or sigrok-cli as root. If the device is recognized there, you need to install the udev rules (see https://sigrok.org/gitweb/?p=libsigrok.git;a=tree;f=contrib) and force udev to reload the rules (a reboot works, too).
Comment 4 Soeren Apel 2018-04-22 11:34:37 CEST
Nicolas, do you have an update for us?
Comment 5 Nicolas 2018-04-24 17:16:34 CEST
Yes, sorry I was away from home for a while.
The installation of udev rules (which I don't very much understand !) solved the problem.
Great, many thanks for the answers.
Comment 6 Marian 2022-11-30 02:33:49 CET
Hello I'm trying to do the same thing as Nicolas, to use Pulseview on Rpi3 and I think I encounter the same problem. I'm working on this from several days, I've tried different things like: updating fx2lafw again and again in different ways, Trying even to build the entire thing on VMBox with Raspbian, I also found a script to compile and install PulseView on Ubuntu Linux
(https://gist.github.com/onetransistor/3e12e2e3a900b1110c111a0efda6ee4a) but unfortunately because I have only 1 Gb Ram I cannot pass the Pluseview build step.  I found some Snap thing build related to the sigrok and use that build in different ways and somehow I manage to make the Pulseview app to work but 
in the end I get the same error :
fx2lafw: Failed to open potential device with VID:PID 0925:3881: LIBUSB_ERROR_ACCESS. 
If you have any advice on how to proceed or have any idea I will be very grateful.