sigrok-meter

From sigrok
Revision as of 04:04, 30 January 2016 by Uwe Hermann (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search
sigrok-meter (multiple devices)

sigrok-meter is a special-purpose GUI for libsigrok (written in Python 2/3, using Qt and the libsigrok Python bindings) which supports certain classes of test & measurement devices that usually provide slowly-updating measurement values, such as multimeters (DMMs) or dataloggers.

It does specifically not support logic analyzers, oscilloscopes, and mixed-signal oscilloscopes (MSOs).

It is licensed under the terms of the GNU GPL, version 3 or later.

NOTE: sigrok-meter is work in progress and is not yet suitable for everyday use!

Status

There have been no official tarball releases, yet.

Distro packagers should not package this, yet.

Requirements

  • git
  • Python (2 or 3)
  • PyQt4 or PySide (both need at least the QtCore and QtGui components)
  • PyQtGraph
  • libsigrok >= 0.4.0 (including the Python bindings)

Fedora (22)

$ sudo dnf install python-pyside python[2|3]-pyqtgraph

Getting the code

$ git clone git://sigrok.org/sigrok-meter

You can also browse the source code via gitweb.